2009-05-12

flashdevelopではtweenは使えない?

このエントリーをブックマークに追加 このエントリーを含むはてなブックマーク
tweenとは、拡大とか移動とかシンプルなflashのアニメーションを簡単に実装するためのオブジェクトです。

利用する際には、
import fl.transitions.Tween;
とするらしいのですが、
flashdevelopを利用している場合は、importできないようです。

設定が悪いのか、TweenはCS3とか製品版で利用できるものということなのか
ちょっとわからないのですが、tweenが使えなくても代わりに
tweener
というものが使えます。

http://d.hatena.ne.jp/flashrod/20070527
が参考になります。

tweenerのzipファイルを取得したら、解凍してできた
caurina
というディレクトリをActionScriptのメインとなるスクリプトを置いているディレクトリに置くことで利用できます。

ブログパーツでは、吹き出しの上にマウスを置くと大きくなるアニメーションで利用してみました。
コメントを投稿